Safari and Panopto Video Issues
Introduction
Staff and students using the macOS (Apple computer) and iOS (Apple mobile device) versions of Safari have reported issues accessing content in Blackboard Learn that contains Panopto videos.
Table of contents
Description of problem
When accessing Blackboard content that contains a Panopto video, users briefly see the content and are then are logged out of their Blackboard Learn session. When users log back in, the Panopto video content begins playing.
Cause
This issue is caused by the Safari browser blocking cross-site tracking (third-party cookies) by default. As the Panopto video tool makes use of cookies to track your session etc. blocking these will cause the issue described above.
Solution
Important: Before making any changes to Safari, please understand that Apple have decided to block cross-site tracking to prevent ad-tracking and keep your personal browsing private.
If you are concerned about privacy or are uncomfortable with making changes to Safari, please consider installing an alternative browser such as Google Chrome (https://www.google.com/intl/en_uk/chrome/ ) and this browser to to access Blackboard Learn instead.
Note: Panopto will shortly be moving away from using cookie-based authentication to using token-based authentication, this will remove the need to use third-party cookies in the future.
The steps are different depending on what version of Safari you are using:
Solution for macOS version of Safari
To allow cross-site tracking (and allow third-party cookies) in the macOS version of Safari:
Open Safari
Select the Safari menu item at the top of the screen and choose Preferences… from the drop-down menu that appears.
The Preferences panel will open.
Select the Privacy tab (highlighted in red below) by clicking on it.
Uncheck the Prevent cross-site tracking checkbox (highlighted in red below).
Note: If the Block all cookies checkbox is checked, uncheck this also.- Restart Safari and try to access the content.
Solution for iOS version of Safari
To allow cross-site tracking (and allow third-party cookies) in the iOS version of Safari:
Find and tap on the Settings button (highlighted in red below):
Scroll down through the options until you find the Safari settings button. Tap on it.
In the Safari Settings panel that opens, scroll down to the PRIVACY & SECURITY section.
Tap on Prevent Cross-Site Tracking button to toggle it OFF. The button will toggle from green to white (highlighted in red below):
Go back to Safari and try to access the content.
Solution for iOS version of Safari (Video version)
A video showing the above steps - without audio - is available below.