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Firefox and Panopto Video Issues

Introduction

Staff and students using the latest versions of Firefox have reported issues accessing content in Blackboard Learn that contains Panopto videos.

Table of contents


Description of problem

When accessing Blackboard Learn content that contains a Panopto video, users briefly see the content and are then are logged out of their Blackboard Learn session.

Cause

This issue is caused by the Firefox browser blocking cross-site tracking (third-party cookies) by default. As the Panopto video tool makes use of cookies to track your session etc. blocking these will cause the issue described above.

Note: Panopto will shortly be moving away from using cookie-based authentication to using token-based authentication, this will remove the need to use third-party cookies in the future.

Solution

Important: Before making any changes to Firefox please understand that Mozilla have decided to block cross-site tracking to prevent ad-tracking and keep your personal browsing private.

If you are concerned about privacy or are uncomfortable with making changes to Firefox, please consider installing an alternative browser such as Google Chrome (https://www.google.com/intl/en_uk/chrome/ ) and use that to access Blackboard Learn instead

To allow cross-site tracking (and allow third-party cookies) in Firefox:

  1. Open Firefox

  2. Select the Open Application Menu button by clicking on the three bar icon to the right of the address bar (highlighted in red below)



  3. From the drop-down menu that appears, select Settings.



  4. The Settings panel will open. Select the Privacy & Security tab in the left hand menu (highlighted in red below):



  5. The Browser Privacy page will open:



  6. By default, your Browser Privacy will be set to Standard (which blocks all Cross-site tracking cookies). You will need to create a custom Browser Privacy policy. To do this, select the Custom option (highlighted in red below):



  7. In the Custom options uncheck the Cookies and Tracking Content options (highlighted in red below):



  8. Your custom settings should now look like this:



  9. Restart Firefox and try to access the content again.