Advice for uploading recordings on slow internet connections
Introduction
A small number of staff have reported that their Panopto recording sessions appear to hang whilst screen recording and accessing online resources at the same time. For example, when demonstrating how to use a website or online database. This issue came to light when staff began recording from home on poor/slow internet connections.
Note: This issue has only occurred in a limited number of instances, but we feel it is important to make users aware of it, as more and more staff come to use the Panopto Recorder.
Table of contents
Cause
By default, the Panopto Recorder progressively uploads a recording in the background whilst the recording is being made. This is done to save time and speed up the recording process.
However, if the Panopto Recorder client is being used on a poor internet connection, this progressive upload can slow down the user’s connection speed to an extent that it prevents them from accessing websites and other online resources at the same time.
Solution
The progressive download option can be disabled in the Panopto Recorder’s settings. Doing so will prevent the application from uploading in the background. Please note that the recording will then be uploaded AFTER the recording has finished, so it is important to give the recorder time to upload before shutting it down.
How you do this depends on whether you are using the macOS or Windows version of the Panopto Recorder client.
Windows Version
To turn off progressive downloads in the Windows version of the Panopto Recorder:
- Open the Panopto Recorder and sign in using your Blackboard Learn login credentials - if you haven’t been signed in automatically.
- Select the Settings button at the top of the Panopto Recorder window (highlighted in red below):
- The Basic Settings window will open.
- Scroll down through the basic settings until you find the App Settings section and look for the Progressively upload while recording option (highlighted in red below).
- Uncheck the Progressively upload while recording checkbox.
- Select the Save button at the bottom of the window to save the changes.
Please Note: The upload process will only begin after you Stop the recording and select the Done button on the Recording Complete window (highlighted in red below)
macOS Version
To turn off progressive downloads in the macOS version of Panopto Recorder:
- Open the Panopto Recorder and sign in using your Blackboard Learn login credentials - if you haven’t been signed in automatically.
- Select the Panopto menu link at the top of your screen and choose Preferences from the drop-down menu that appears (highlighted in red below):
- The Panopto Preferences window will open:
- Look for the Upload Recordings Automatically option (highlighted in red below). Uncheck it.
- Select the OK button to save the changes.
Please Note: Unlike the Windows version of the Panopto Recorder, the recording will not upload after you Stop the recording and select the Done button. Instead, the recording is saved as an Offline recording and the user must manually start the upload process.
To do this:
- After you have stopped the recording, on the Recording Complete window that opens, select the Done button (highlighted in red below)
- You will be taken to the Manage Recordings window:
- The Session List shows all recordings. By default, the most recent recording will be shown at the top of the list. Select the recording you want to manually upload by selecting its session title (highlighted in red below):
- Now, in the Recording Details panel at the bottom right of the window, select the Choose Folder and upload button (highlighted in red below):
- Folder: My Folder will become a dropdown menu button (highlighted in red below).
- Select the My Folder dropdown menu button to see a list of modules you have access to and that are provisioned with Panopto. Choose the module area you want to upload the recording to.
- Select the Upload button to upload the video to the selected module area.